Dendroboard banner
1 - 18 of 18 Posts

·
Premium Member
Joined
·
13,230 Posts
Discussion Starter · #1 ·
Well after a horrible day at work, and then to come home and find my piece of crap van leaking coolant(never get a dodge caravan), and having a sick pumilio I found yesterday... I come home to my first imitator egg. Nice to know something made my smile today... wow is it bed time yet...

Had to post it, sorry for the rant, but a long day... and i'm all out of beer...
 

·
Premium Member
Joined
·
13,230 Posts
Discussion Starter · #3 ·
2 are over a year, I thought they might be a pair at first, but are 2 males. I just added a female about 2 months ago that is about 5-6 months old or so.

So far I think have 2.1.0 in my 15gal high (the one the laid in) and then 1.1.1 in my 10gal.
 

·
Premium Member
Joined
·
13,230 Posts
Discussion Starter · #5 ·
Not sure just started to seem thinner. Yea one of my bastimentos. We will see, but so far not looking good. Seems thinner than yesterday. Still active and moving around, but may not be eating. Could be too late, I am trying to treat it, we will see.

Ed Martin said:
What do you think is wrong with the pumilio? Is it one of your bastimentos (sp)?
Ed
 
G

·
congrats on the egg! Best of luck with the pumilio. Where did you imitators lay? I've been rearranging film canisters lately in hopes of sparking more interest. If nothing else, I will transfer them to a viv that has nothing but philodendrons.

-Bill J,
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top