Dendroboard banner
1 - 2 of 2 Posts

·
Registered
Joined
·
608 Posts
Discussion Starter · #1 ·
Ok, my poor little imitator pair that have been laying like crazy finally decided they were tired of the big thief stealing their eggs. So, right now, they are laying more eggs at the very back of the tank under a leaf that is stuck to the side of the tank. I have several tads in the water now, so I figured that I'd leave them.

Now, on the the problem and where I need ideas...I set these guys up in this tank as froglets, and just happened to luck out that they were male and female...they started laying before I tried to actually sex them out. There are no broms in there, so I want to make sure that there are enough places for him to deposit tads. So, any suggestions to what I should do? Should I add a brom in there quickly or will that mess them up? I know changing tank stuff around will usually throw off a breeding pair, but I guess if the eggs are laid and fertilized that slowing them down won't necessarily be a bad thing.

What other options are there?

Thanks so much for any input!

Kristen
 

·
Registered
Joined
·
608 Posts
Discussion Starter · #4 ·
There are some film canisters in there, but they are all upside down...so I'll turn some right side up. The bum deal about film canisters is that it would be hard to see the tad(s)...I'm sure they're hard to find in broms too, though.

Brian, where did yours end up depositing the tad? Did you just place the cups on the bottom of the tank? I think I would worry about frogs getting in there and drowning.

Should I put these film canisters close to the bottom or wherever?

Thanks!

Kristen
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top