Dendroboard banner
1 - 4 of 4 Posts

·
Registered
Joined
·
542 Posts
Discussion Starter · #1 ·
So I have a pair of azureus that I had bought and they laid for the seller multiple times producing hundreds of frogs. Once I got them and they started laying for me they was giving me good healthy tads and frogs. Over the past 2-3 weeks they have started laying bad eggs again.

They are eating dusted flies once a week and temps and everything seem to be normal so im not sure whats going on. Any ideas?
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #3 ·
well see they really had a break more or less because once I bought them they didnt breed for 6-8 months for me. Over the past 2months maybe they started laying good viable eggs again and now just over the past week or 2 they started laying bad eggs again.

Im using a new batch of repashy that I bought not even a month ago. I havent really even been giving them extra feedings and extra hand misting to spur breeding so Im not sure whats brought on the bad eggs
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #5 ·
Are you only feeding the frogs once a week? Or are you feeding them multiple times and only dusting once a week?

Ed
they eat every other day but the flies only get dusted once a week. I pulled a clutch last night of 4 two bad eggs and 2 good eggs. I dont know why they started laying bad ones again
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #7 ·
Hm well that may could be it. I thought dusting with the repashy could be done to much and that would cause just as many problems. Whats the best schedule for dusting?
 
1 - 4 of 4 Posts
Top