What's wrong with this plant? - Dendroboard
Dendroboard

Go Back   Dendroboard > Vivariums > Plants
Register Blogs FAQ Calendar Mark Forums Read Advertise

Support Our Sponsors
No Threads to Display.

facebook

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-04-2020, 03:32 AM
Member
 
Join Date: Jul 2011
Location: Sioux falls, SD
Posts: 119
Thanks: 4
Thanked 2 Times in 2 Posts
Default What's wrong with this plant?

I just got done building my new viv and I have this fern that's in a backgound planter about 8in away from my lights, and the planter is very close to a waterfall. The water does not go in the planter but definetly makes it moist in that area of the backgound. The planter has a drain tube. I have only had it in the viv for a week. It looks like its slowly dying. I'm thinking it's to much water but not sure?
Attached Images
File Type: jpg 20200103_181846.jpg (100.3 KB, 28 views)
File Type: jpg 20200102_193501.jpg (84.6 KB, 23 views)
File Type: jpg 20200103_181830.jpg (101.4 KB, 22 views)
File Type: jpg 20200102_193520.jpg (100.6 KB, 22 views)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 07:36 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.