GE II just tastes bad! - Dendroboard
Dendroboard

Go Back   Dendroboard > Vivariums > Parts & Construction
Register Blogs FAQ Calendar Mark Forums Read Advertise

Support Our Sponsors
No Threads to Display.

facebook

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-10-2007, 02:43 AM
Member
 
Join Date: Aug 2006
Location: Colorado
Posts: 251
Thanks: 0
Thanked 0 Times in 0 Posts
Default GE II just tastes bad!

I don't know about everyone else but I think GE II tastes really nasty. Now before anyone starts in with the questions, let me qualify that statement.
I wasn't eatin the stuff like a kindergartner eats Elmers glue.
I was simply mushing it around while applying my cocofiber background. The fumes just gave me this gnarly flavor in my mouth. You know if you kinda exhale through your nose, sometimes you can taste things? That's what I'm talking about here. Anyone else have this experience?
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-10-2007, 03:16 AM
nyfrogs's Avatar
Member
 
Join Date: May 2005
Location: Richmond VA
Posts: 774
Thanks: 11
Thanked 13 Times in 12 Posts
Default

elmers glue tasts good
Reply With Quote
  #3 (permalink)  
Old 01-10-2007, 03:35 AM
Member
 
Join Date: Apr 2006
Location: UK, East coast-ish!
Posts: 555
Thanks: 0
Thanked 0 Times in 0 Posts
Default

When i coated the inside of my DIY 52 GAL Hex i used about 8 or 9 tubes in one go..

I tasted it all right, i had a head ache for two days. That was done in an open garage with a fan blowing the fumes away from me!!!

Oh well at least the inside of my lungs are now waterproof... may come in handy one day :lol: :lol:

Regards

Steve
__________________
Sniff Sniff, I ain't got no frogs no more!
Reply With Quote
 
  #4 (permalink)  
Old 01-10-2007, 03:54 AM
 
Join Date: Dec 2006
Posts: 862
Thanks: 0
Thanked 0 Times in 0 Posts
Default

sometimes i get high in my room when working on a viv
Not on purpose, just cuz the fumes are freakin crazy.

Try doing algebra after working with this shiznit
Reply With Quote
  #5 (permalink)  
Old 01-10-2007, 11:47 AM
Member
 
Join Date: Oct 2006
Location: Oklahoma
Posts: 393
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I ended up using 3 or 4 tubes on my 40 gallon and was surprised by how little smell there was. The first time I used a fan and had a door open. After that I just put in on with the door closed and usually not even a fan. Of course, my nose does not work that well, so maybe that explains it.
Reply With Quote
  #6 (permalink)  
Old 01-11-2007, 01:26 AM
TWI/ASN
 
Join Date: Sep 2006
Location: Allendale, NJ
Posts: 477
Thanks: 3
Thanked 1 Time in 1 Post
Default

MMMMMM, Drugs are baaaaaaaaad, mmmmmmmmk. Drugs are baaaaaaad mmmmmmmmk. :lol:
__________________
Imitator; Orange lamasi; Intermedius Tarlton; Auratus CR; Alanis
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
GE II just tastes bad! Smogre General Discussion 3 01-01-1970 12:00 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 02:19 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.