Dead tadpole? - Dendroboard
Dendroboard

Go Back   Dendroboard > Blogs > markbudde
Register Blogs FAQ Calendar Mark Forums Read Advertise

Support Our Sponsors
No Threads to Display.

facebook

Rate this Entry

Dead tadpole?

Posted 09-15-2008 at 03:02 AM by markbudde

Today I added some oak leaf litter to the viv and checked on the tadpole while I was at it. The tadpole looked like I was dead. Before, when I shined my light at it, it would wiggle, but now there was no wiggling. Also, the 2 dead eggs around it were oozing the rotten yolk all around it. Also, the male didn't seem to be checking on it anymore. So I did what any impatient frogger would do, and added some water to it. It still didn't move, but with it came out of the egg, with its tail bent a little. I was going to keep it on my shelf until I was sure it was dead, but then it twitched a little. It was in distilled water, which it probably shouldn't have been in (but was all I had), so I quickly dropped it into a brom, figuring that the brom water would be more conditioned. It didn't move again. I'll check on it again in a few days, but my expectations aren't too high.

I also changed the film canister out with a clear 50 mL conical tube. I hadn't gotten new eggs in a week, so we'll see if they like it.

-mark
Posted in Uncategorized
Views 614 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 
Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 11:28 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.