Dendroboard - View Single Post - mites killing my plants!?!
Dendroboard

Go Back   Dendroboard
Register Blogs FAQ Calendar Mark Forums Read Advertise

Support Our Sponsors
No Threads to Display.

facebook

View Single Post
  #1 (permalink)  
Old 04-30-2005, 04:43 AM
RivetChick RivetChick is offline
Member
 
Join Date: Feb 2005
Location: NashVegas, TN
Posts: 116
Thanks: 0
Thanked 0 Times in 0 Posts
Default mites killing my plants!?!

ok,
two weeks ago, i bought a lot of plants at a local nursery for my new vivarium i am setting up. i noticed this week that some of the plants aren't doing so good (they are still in their original pots waiting to be planted). i took a closer look to see some tiny mite looking insects crawling on the soil. i have seen these on my bonsai trees before and they have nearly killed several of my trees. i usually break out the garden pesticide, but i can't do that to plants intended on going in my vivarium.
i have run some soapy water through the infected plants but im not entirely convinced it will work (in fact, it hasnt). i do not want to accidentally put a pest into my vivarium that will kill the plants. this is extremely frustrating since i had hoped to plant the vivarium this weekend. any suggestions?
the plants are as follows:
cyclamen hederifolium "cyclamen",
ploystichum polyblepharum "tassel fern",
athyrium "japanese painted fern"

Thanks, ~Lauren
__________________
1.1.0 Hawaiian Auratus (reticulated), 2.1.? Leucomelas, 3.2.0 Cobalt Tincs, 1.0.0 Camo Auratus, 3.0.1 Yellowback Tincs, 0.0.3 Azureus and lots of tads!
http://nashvillecraftmafia.com
Reply With Quote
 
Powered by vBadvanced CMPS v3.2.3

All times are GMT. The time now is 04:58 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.